Network Connectivity - London
Incident Report for Clerk.io
Resolved
Everything is back to normal.
Posted Dec 17, 2015 - 13:42 CET
Identified
Some customers may currently experience slow response times or instability due to network connectivity errors at our London data center.

Our hosting provider is woking on it as we speak.
Posted Dec 17, 2015 - 13:17 CET