London Connectivity Issues - continued
Incident Report for Clerk.io
Resolved
And now we seem to be back.

We will continue to monitor the situation.

Happy New Year
Posted Dec 31, 2015 - 17:01 CET
Monitoring
It looks like the problems are continuing.

We will keep monitoring the situation.
Posted Dec 31, 2015 - 16:17 CET