DDOS Attack
Incident Report for Clerk.io
Resolved
Everything is now running smoothly again.

The DDOS attack has been contained but we continue to monitor the situation.
Posted Apr 30, 2015 - 00:25 CEST
Investigating
We are currently experiencing a DDOS attack.

We are on the case but there will be some instability.
Posted Apr 30, 2015 - 00:18 CEST