5 minute API outage
Incident Report for Clerk.io
Resolved
We have had no further issues - everything is running smoothly.

The issue was caused by too many batch operations running at the same time causing new incoming request to queue up. We have now added a limit to the number of batch jobs and will be working on a smarter scheduler for batching.
Posted Dec 01, 2014 - 18:11 CET
Monitoring
We have had a short API outage between 15:07 to 15:12. Our support team were alarmed immediately and the issue were resolved within 5 minutes.

The outage were due to an extreme spike in database CPU usage. As of now we don't know the exact cause of the spike since we always focus on getting the service up and running again.

We are monitoring the situation closely and will be back with an update when we have identified the cause.
Posted Dec 01, 2014 - 15:22 CET