DNS issues
Incident Report for Clerk.io
Resolved
Linode have now resolved the issue and all DNS servers are up and running again.
Posted Apr 30, 2014 - 14:01 CEST
Update
Quick Update: We have now tested the global DNS avaliablity of clerk.io via several DNS testing tools. The domain is globaly avaliable but ns3.linode.com seems to be down.

Linode is looking in to this issue.
Posted Apr 30, 2014 - 13:53 CEST
Monitoring
Our DNS provider (Linode) is having issues with one of their DNS servers (don't worry, they have 5). Though this should not affect the availability of our service we have been informed that some ISPs might not resolve clerk.io correctly.

We are awaiting Linode for further updates.
Posted Apr 30, 2014 - 13:35 CEST