SSL Certificate Issue
Incident Report for Clerk.io
Resolved
The certificate has now been configured correctly.
Posted Aug 01, 2015 - 13:11 CEST
Identified
A malconfiguration of a SSL certificate is causing problems for HTTPS connections as the moment.

We are working on fixing the issue as we speak.

A update will follows here as soon as it is fixed.
Posted Aug 01, 2015 - 13:08 CEST