Intermittent failures to v2/search and v2/recommendations
Resolved
Feb 24 at 07:25 CET
Services have recovered.
Post-mortem analysis underway.
Affected services
Created
Feb 24 at 07:19 CET
During a brief window from 07:19 (CET) to 07:24 (CET) today a faulty deployment let to instability in the API that handles search and recommendations for the /v2/ API routes.
The cause was a feature update behaving differently in development vs production. The error was highlighted within minutes and the deployment was rolled back.
We will perform a root cause analysis, finding out both why the bug doesn't trigger during development and how to automate detection of this case to prevent it from happening again.
We sincerely apologize for any inconvenience this has caused and will continue striving to deliver an even better service.
Affected services